Re: [PATCH v3 1/3] mm: replace memmap_context by meminit_context

From: Laurent Dufour
Date: Wed Sep 16 2020 - 03:29:45 EST

Le 16/09/2020 à 08:33, Greg Kroah-Hartman a écrit :
On Tue, Sep 15, 2020 at 03:26:24PM +0200, Laurent Dufour wrote:
The memmap_context enum is used to detect whether a memory operation is due
to a hot-add operation or happening at boot time.

Make it general to the hotplug operation and rename it as meminit_context.

There is no functional change introduced by this patch

Suggested-by: David Hildenbrand <david@xxxxxxxxxx>
Signed-off-by: Laurent Dufour <ldufour@xxxxxxxxxxxxx>
arch/ia64/mm/init.c | 6 +++---
include/linux/mm.h | 2 +-
include/linux/mmzone.h | 11 ++++++++---
mm/memory_hotplug.c | 2 +-
mm/page_alloc.c | 10 +++++-----
5 files changed, 18 insertions(+), 13 deletions(-)


This is not the correct way to submit patches for inclusion in the
stable kernel tree. Please read:
for how to do this properly.


Hi Greg,

I'm sorry, I read that document few days ago before sending the series and again this morning, but I can't figure out what I missed (following option 1).

Should the "Cc: stable@xxxxxxxxxxxxxxx" tag be on each patch of the series even if the whole series has been sent to stable ?

Should the whole series sent again (v4) instead of sending a fix as a reply to ?