Re: [PATCH -next] gpu: host1x: simplify the return expression of host1x_cdma_init()

From: Mikko Perttunen
Date: Mon Sep 21 2020 - 09:12:45 EST


On 9/21/20 4:10 PM, Qinglang Miao wrote:
Simplify the return expression.

Signed-off-by: Qinglang Miao <miaoqinglang@xxxxxxxxxx>
---
drivers/gpu/host1x/cdma.c | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/drivers/gpu/host1x/cdma.c b/drivers/gpu/host1x/cdma.c
index e8d3fda91..08a0f9e10 100644
--- a/drivers/gpu/host1x/cdma.c
+++ b/drivers/gpu/host1x/cdma.c
@@ -448,8 +448,6 @@ void host1x_cdma_update_sync_queue(struct host1x_cdma *cdma,
*/
int host1x_cdma_init(struct host1x_cdma *cdma)
{
- int err;
-
mutex_init(&cdma->lock);
init_completion(&cdma->complete);
@@ -459,11 +457,7 @@ int host1x_cdma_init(struct host1x_cdma *cdma)
cdma->running = false;
cdma->torndown = false;
- err = host1x_pushbuffer_init(&cdma->push_buffer);
- if (err)
- return err;
-
- return 0;
+ return host1x_pushbuffer_init(&cdma->push_buffer);

IMHO, this makes it less readable since now it kind of looks like host1x_pushbuffer_init is returning some meaningful value, instead of the code just handling error values in a sequence.

Mikko

}
/*