[tip: core/rcu] docs: Fix typo in synchronize_rcu() function name

From: tip-bot2 for Tobias Klauser
Date: Fri Oct 09 2020 - 02:36:07 EST


The following commit has been merged into the core/rcu branch of tip:

Commit-ID: 77f808607a62c3685381a5732a88b30bad8893b5
Gitweb: https://git.kernel.org/tip/77f808607a62c3685381a5732a88b30bad8893b5
Author: Tobias Klauser <tklauser@xxxxxxxxxx>
AuthorDate: Thu, 02 Jul 2020 18:28:10 +02:00
Committer: Paul E. McKenney <paulmck@xxxxxxxxxx>
CommitterDate: Mon, 24 Aug 2020 14:29:16 -07:00

docs: Fix typo in synchronize_rcu() function name

s/sychronize_rcu/synchronize_rcu/

Signed-off-by: Tobias Klauser <tklauser@xxxxxxxxxx>
Signed-off-by: Paul E. McKenney <paulmck@xxxxxxxxxx>
---
Documentation/RCU/whatisRCU.rst | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Documentation/RCU/whatisRCU.rst b/Documentation/RCU/whatisRCU.rst
index c7f147b..fb3ff76 100644
--- a/Documentation/RCU/whatisRCU.rst
+++ b/Documentation/RCU/whatisRCU.rst
@@ -360,7 +360,7 @@ order to amortize their overhead over many uses of the corresponding APIs.

There are at least three flavors of RCU usage in the Linux kernel. The diagram
above shows the most common one. On the updater side, the rcu_assign_pointer(),
-sychronize_rcu() and call_rcu() primitives used are the same for all three
+synchronize_rcu() and call_rcu() primitives used are the same for all three
flavors. However for protection (on the reader side), the primitives used vary
depending on the flavor: