Re: [PATCH v1 06/29] virtio-mem: generalize virtio_mem_owned_mb()

From: David Hildenbrand
Date: Thu Oct 15 2020 - 04:37:20 EST


On 15.10.20 10:32, Wei Yang wrote:
> On Mon, Oct 12, 2020 at 02:53:00PM +0200, David Hildenbrand wrote:
>> Avoid using memory block ids. Rename it to virtio_mem_contains_range().
>>
>> Cc: "Michael S. Tsirkin" <mst@xxxxxxxxxx>
>> Cc: Jason Wang <jasowang@xxxxxxxxxx>
>> Cc: Pankaj Gupta <pankaj.gupta.linux@xxxxxxxxx>
>> Signed-off-by: David Hildenbrand <david@xxxxxxxxxx>
>> ---
>> drivers/virtio/virtio_mem.c | 9 +++++----
>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/virtio/virtio_mem.c b/drivers/virtio/virtio_mem.c
>> index 6bbd1cfd10d3..821143db14fe 100644
>> --- a/drivers/virtio/virtio_mem.c
>> +++ b/drivers/virtio/virtio_mem.c
>> @@ -500,12 +500,13 @@ static bool virtio_mem_overlaps_range(struct virtio_mem *vm,
>> }
>>
>> /*
>> - * Test if a virtio-mem device owns a memory block. Can be called from
>> + * Test if a virtio-mem device contains a given range. Can be called from
>> * (notifier) callbacks lockless.
>> */
>> -static bool virtio_mem_owned_mb(struct virtio_mem *vm, unsigned long mb_id)
>> +static bool virtio_mem_contains_range(struct virtio_mem *vm, uint64_t start,
>> + uint64_t size)
>> {
>> - return mb_id >= vm->first_mb_id && mb_id <= vm->last_mb_id;
>> + return start >= vm->addr && start + size <= vm->addr + vm->region_size;
>
> Do we have some reason to do this change?

Big Block Mode :)

--
Thanks,

David / dhildenb