Re: [PATCH 1/2 v2] dma-iommu: use static-key to minimize the impact in the fast-path

From: Christoph Hellwig
Date: Tue Jan 19 2021 - 10:29:48 EST


On Tue, Jan 19, 2021 at 07:16:15PM +0800, Lianbo Jiang wrote:
> +static DEFINE_STATIC_KEY_FALSE(__deferred_attach);

Why the strange underscores? Wouldn't iommu_deferred_attach_enabled
be a better name?

> - if (unlikely(iommu_dma_deferred_attach(dev, domain)))
> + if (static_branch_unlikely(&__deferred_attach) &&
> + iommu_dma_deferred_attach(dev, domain))

Also insted of duplicating this logic in three places, maybe rename
iommu_dma_deferred_attach to __iommu_dma_deferred_attach and create
a small inline wrapper for it?