Re: [STABLE BACKPORT 4.19.y and 5.14.y] compiler.h: Raise minimum version of GCC to 5.1 for arm64

From: Greg KH
Date: Wed Jan 20 2021 - 07:07:13 EST

On Mon, Jan 18, 2021 at 01:57:00PM +0000, Will Deacon wrote:
> commit dca5244d2f5b94f1809f0c02a549edf41ccd5493 upstream.
> GCC versions >= 4.9 and < 5.1 have been shown to emit memory references
> beyond the stack pointer, resulting in memory corruption if an interrupt
> is taken after the stack pointer has been adjusted but before the
> reference has been executed. This leads to subtle, infrequent data
> corruption such as the EXT4 problems reported by Russell King at the
> link below.
> Life is too short for buggy compilers, so raise the minimum GCC version
> required by arm64 to 5.1.
> Reported-by: Russell King <linux@xxxxxxxxxxxxxxx>
> Suggested-by: Arnd Bergmann <arnd@xxxxxxxxxx>
> Signed-off-by: Will Deacon <will@xxxxxxxxxx>
> Tested-by: Nathan Chancellor <natechancellor@xxxxxxxxx>
> Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx>
> Reviewed-by: Nathan Chancellor <natechancellor@xxxxxxxxx>
> Acked-by: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>
> Cc: <stable@xxxxxxxxxxxxxxx> # 4.19.y and 5.4.y only

All now queued up, thanks!

greg k-h