Re: [PATCH i2c-next] i2c: designware: Consolidate pci_free_irq_vectors to a single place

From: Andy Shevchenko
Date: Mon Feb 15 2021 - 08:23:27 EST


On Sun, Feb 14, 2021 at 02:45:29PM +0800, Dejin Zheng wrote:
> Consolidate pci_free_irq_vectors to a single place using "goto free_irq"
> for simplify the code.

One nit below, after addressing:
Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>

...

> +free_irq:

It's quite confusing name. I would expect to see here (with current proposal)
*free_irq() call, but no, I don't see a such.

Please, change to something like
err_pci_free_irq_vectors:
or alternatively
err_free_irq_vectors:
however I think first one is disambiguous.

> + pci_free_irq_vectors(pdev);
> + return r;

--
With Best Regards,
Andy Shevchenko