Re: [PATCH v2 3/4] i2c: designware: Use the correct name of device-managed function
From: Andy Shevchenko
Date: Tue Feb 16 2021 - 09:41:56 EST
On Tue, Feb 16, 2021 at 10:18:09PM +0800, Dejin Zheng wrote:
> Use the new function pcim_alloc_irq_vectors() to allocate IRQ vectors,
> the pcim_alloc_irq_vectors() function, an explicit device-managed version
> of pci_alloc_irq_vectors(). If pcim_enable_device() has been called
> before, then pci_alloc_irq_vectors() is actually a device-managed
> function. It is used here as a device-managed function, So replace it
> with pcim_alloc_irq_vectors().
...
> - r = pci_alloc_irq_vectors(pdev, 1, 1, PCI_IRQ_ALL_TYPES);
> + r = pcim_alloc_irq_vectors(pdev, 1, 1, PCI_IRQ_ALL_TYPES);
> if (r < 0)
> return r;
It's good, but now why do we have pci_free_irq_vectors() in the same file?
--
With Best Regards,
Andy Shevchenko