- Move to another file, kernel/printk/debug_formats.c or similar
Just to be sure. The filename should be ideally based on the configure
option and API names, e.g. formats_index.c or so.
The printk_ prefix is not strictly necessary. The file is in printk/
directory. IMHO, we should have used ringbuffer.c but ...
- Use `struct module *mod` instead of calling it module
- Add documentation for printk_fmt_sec (or whatever it will be called)
- Rename things to pf_, pi_, or something
- See if it's safe to pass a printk_fmt_sec to seq_file instead of a module
Also it might be needed to store the pointer to struct module.
Both things together might allow to remove the global hash table and likely
even the mutex.
- Handle cont + level
- Don't expose level/KERN_SOH directly
I can't remember anything else. I am curious how v5 would look like.