Re: [PATCH v5 2/5] mm,compaction: Let isolate_migratepages_{range,block} return error codes

From: Vlastimil Babka
Date: Fri Mar 19 2021 - 06:15:21 EST


On 3/19/21 10:57 AM, Oscar Salvador wrote:
> On Thu, Mar 18, 2021 at 12:36:52PM +0100, Michal Hocko wrote:
>> Yeah, makes sense. I am not a fan of the above form of documentation.
>> Btw. maybe renaming the field would be even better, both from the
>> intention and review all existing users. I would go with pfn_iter or
>> something that wouldn't make it sound like migration specific.
>
> Just to be sure we are on the same page, you meant something like the following
> (wrt. comments):
>
> /*
> * compact_control is used to track pages being migrated and the free pages
> * they are being migrated to during memory compaction. The free_pfn starts
> * at the end of a zone and migrate_pfn begins at the start. Movable pages
> * are moved to the end of a zone during a compaction run and the run
> * completes when free_pfn <= migrate_pfn
> *
> * freepages: List of free pages to migrate to
> * migratepages: List of pages that need to be migrated
> * nr_freepages: Number of isolated free pages
> ...
> */
> struct compact_control {
> struct list_head freepages;
> ...

No I meant this:

--- a/mm/internal.h
+++ b/mm/internal.h
@@ -225,7 +225,13 @@ struct compact_control {
unsigned int nr_freepages; /* Number of isolated free pages */
unsigned int nr_migratepages; /* Number of pages to migrate */
unsigned long free_pfn; /* isolate_freepages search base */
- unsigned long migrate_pfn; /* isolate_migratepages search base */
+ /*
+ * Acts as an in/out parameter to page isolation for migration.
+ * isolate_migratepages uses it as a search base.
+ * isolate_migratepages_block will update the value to the next pfn
+ * after the last isolated one.
+ */
+ unsigned long migrate_pfn;
unsigned long fast_start_pfn; /* a pfn to start linear scan from */
struct zone *zone;
unsigned long total_migrate_scanned;


> With the preface that I am not really familiar with compaction code:
>
> About renaming the variable to something else, I wouldn't do it.
> I see migrate_pfn being used in contexts where migration gets mentioned,
> e.g:

I also don't like the renaming much. "Migration" is important as this is about
pages to be migrated, and there's "free_pfn" field tracking scan for free pages as
migration target. So the name can't be as generic as "pfn_iter".

> /*
> * Briefly search the free lists for a migration source that already has
> * some free pages to reduce the number of pages that need migration
> * before a pageblock is free.
> */
> fast_find_migrateblock(struct compact_control *cc)
> {
> ...
> unsigned long pfn = cc->migrate_pfn;
> }
>
> isolate_migratepages()
> /* Record where migration scanner will be restarted. */
>
>
> So, I would either stick with it, or add a new 'iter_pfn'/'next_pfn_scan'
> field if we feel the need to.
>
>