Re: [External] Re: [PATCH v4 4/5] mm: memcontrol: use obj_cgroup APIs to charge kmem pages

From: Muchun Song
Date: Fri Mar 19 2021 - 11:47:11 EST


On Fri, Mar 19, 2021 at 9:59 PM Shakeel Butt <shakeelb@xxxxxxxxxx> wrote:
>
> On Thu, Mar 18, 2021 at 9:05 PM Muchun Song <songmuchun@xxxxxxxxxxxxx> wrote:
> >
> > On Fri, Mar 19, 2021 at 11:40 AM Shakeel Butt <shakeelb@xxxxxxxxxx> wrote:
> > >
> > > On Thu, Mar 18, 2021 at 4:08 AM Muchun Song <songmuchun@xxxxxxxxxxxxx> wrote:
> > > >
> > > [...]
> > > >
> > > > +static inline struct mem_cgroup *get_obj_cgroup_memcg(struct obj_cgroup *objcg)
> > >
> > > I would prefer get_mem_cgroup_from_objcg().
> >
> > Inspired by obj_cgroup_memcg() which returns the memcg from objcg.
> > So I introduce get_obj_cgroup_memcg() which obtains a reference of
> > memcg on the basis of obj_cgroup_memcg().
> >
> > So that the names are more consistent. Just my thought.
> >
> > So should I rename it to get_mem_cgroup_from_objcg?
> >
>
> If you look at other functions which get reference on mem_cgroup, they
> have the format of get_mem_cgroup_*. Similarly the current function to
> get a reference on obj_cgroup is get_obj_cgroup_from_current().
>
> So, from the name get_obj_cgroup_memcg(), it seems like we are getting
> reference on obj_cgroup but the function is getting reference on
> mem_cgroup.

Make sense. I will use get_mem_cgroup_from_objcg(). Thanks.

>
> > >
> > > > +{
> > > > + struct mem_cgroup *memcg;
> > > > +
> > > > + rcu_read_lock();
> > > > +retry:
> > > > + memcg = obj_cgroup_memcg(objcg);
> > > > + if (unlikely(!css_tryget(&memcg->css)))
> > > > + goto retry;
> > > > + rcu_read_unlock();
> > > > +
> > > > + return memcg;
> > > > +}
> > > > +
> > > > #ifdef CONFIG_MEMCG_KMEM
> > > > int memcg_alloc_page_obj_cgroups(struct page *page, struct kmem_cache *s,
> > > > gfp_t gfp, bool new_page)
> > > > @@ -3070,15 +3088,8 @@ static int obj_cgroup_charge_pages(struct obj_cgroup *objcg, gfp_t gfp,
> > > > struct mem_cgroup *memcg;
> > > > int ret;
> > > >
> > > > - rcu_read_lock();
> > > > -retry:
> > > > - memcg = obj_cgroup_memcg(objcg);
> > > > - if (unlikely(!css_tryget(&memcg->css)))
> > > > - goto retry;
> > > > - rcu_read_unlock();
> > > > -
> > > > + memcg = get_obj_cgroup_memcg(objcg);
> > > > ret = __memcg_kmem_charge(memcg, gfp, nr_pages);
> > >
> > > Why not manually inline __memcg_kmem_charge() here? This is the only user.
> > >
> > > Similarly manually inline __memcg_kmem_uncharge() into
> > > obj_cgroup_uncharge_pages() and call obj_cgroup_uncharge_pages() in
> > > obj_cgroup_release().
> >
> > Good point. I will do this.
> >
> > >
> > > > -
> > > > css_put(&memcg->css);
> > > >
> > > > return ret;
> > > > @@ -3143,18 +3154,18 @@ static void __memcg_kmem_uncharge(struct mem_cgroup *memcg, unsigned int nr_page
> > > > */
> > > > int __memcg_kmem_charge_page(struct page *page, gfp_t gfp, int order)
> > > > {
> > > > - struct mem_cgroup *memcg;
> > > > + struct obj_cgroup *objcg;
> > > > int ret = 0;
> > > >
> > > > - memcg = get_mem_cgroup_from_current();
> > >
> > > This was the only use of get_mem_cgroup_from_current(). Why not remove it?
> >
> > I saw a potential user.
> >
> > [PATCH v10 0/3] Charge loop device i/o to issuing cgroup
> >
> > To avoid reintroducing them. So I did not remove it.
> >
>
> Don't worry about that. Most probably that user would be changing this
> function, so it would to better to introduce from scratch.

OK. I will remove get_mem_cgroup_from_current(). Thanks for
your suggestions.