Re: [PATCH] power-supply: use kobj_to_dev()

From: Sebastian Reichel
Date: Mon Mar 22 2021 - 10:09:38 EST


Hi,

On Tue, Mar 16, 2021 at 02:54:12PM +0800, Jian Dong wrote:
> From: dongjian <dongjian@xxxxxxxxxx>
>
> Use kobj_to_dev() instead of open-coding it
>
> Signed-off-by: dongjian <dongjian@xxxxxxxxxx>
> ---

Thanks, queued.

-- Sebastian

> drivers/power/supply/ds2781_battery.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/power/supply/ds2781_battery.c b/drivers/power/supply/ds2781_battery.c
> index 3df3c82..05b859b 100644
> --- a/drivers/power/supply/ds2781_battery.c
> +++ b/drivers/power/supply/ds2781_battery.c
> @@ -626,7 +626,7 @@ static ssize_t ds2781_read_param_eeprom_bin(struct file *filp,
> struct bin_attribute *bin_attr,
> char *buf, loff_t off, size_t count)
> {
> - struct device *dev = container_of(kobj, struct device, kobj);
> + struct device *dev = kobj_to_dev(kobj);
> struct power_supply *psy = to_power_supply(dev);
> struct ds2781_device_info *dev_info = to_ds2781_device_info(psy);
>
> @@ -639,7 +639,7 @@ static ssize_t ds2781_write_param_eeprom_bin(struct file *filp,
> struct bin_attribute *bin_attr,
> char *buf, loff_t off, size_t count)
> {
> - struct device *dev = container_of(kobj, struct device, kobj);
> + struct device *dev = kobj_to_dev(kobj);
> struct power_supply *psy = to_power_supply(dev);
> struct ds2781_device_info *dev_info = to_ds2781_device_info(psy);
> int ret;
> @@ -671,7 +671,7 @@ static ssize_t ds2781_read_user_eeprom_bin(struct file *filp,
> struct bin_attribute *bin_attr,
> char *buf, loff_t off, size_t count)
> {
> - struct device *dev = container_of(kobj, struct device, kobj);
> + struct device *dev = kobj_to_dev(kobj);
> struct power_supply *psy = to_power_supply(dev);
> struct ds2781_device_info *dev_info = to_ds2781_device_info(psy);
>
> @@ -685,7 +685,7 @@ static ssize_t ds2781_write_user_eeprom_bin(struct file *filp,
> struct bin_attribute *bin_attr,
> char *buf, loff_t off, size_t count)
> {
> - struct device *dev = container_of(kobj, struct device, kobj);
> + struct device *dev = kobj_to_dev(kobj);
> struct power_supply *psy = to_power_supply(dev);
> struct ds2781_device_info *dev_info = to_ds2781_device_info(psy);
> int ret;
> --
> 1.9.1
>

Attachment: signature.asc
Description: PGP signature