Re: [PATCH] i915_vma: Rename vma_lookup to i915_vma_lookup

From: Daniel Vetter
Date: Wed Mar 24 2021 - 06:02:49 EST


On Tue, Mar 23, 2021 at 01:42:21PM +0000, Liam Howlett wrote:
> Use i915 prefix to avoid name collision with future vma_lookup() in mm.
>
> Signed-off-by: Liam R. Howlett <Liam.Howlett@xxxxxxxxxx>
> Reviewed-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx>

Applied to i915-gem-next branch for 5.13. We have a bit a branch shuffling
going on right now so unusal path, it should show up in linux-next through
drm-next hopefully this week still.
-Daniel

> ---
> drivers/gpu/drm/i915/i915_vma.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_vma.c b/drivers/gpu/drm/i915/i915_vma.c
> index caa9b041616b..ee0028c697f6 100644
> --- a/drivers/gpu/drm/i915/i915_vma.c
> +++ b/drivers/gpu/drm/i915/i915_vma.c
> @@ -230,7 +230,7 @@ vma_create(struct drm_i915_gem_object *obj,
> }
>
> static struct i915_vma *
> -vma_lookup(struct drm_i915_gem_object *obj,
> +i915_vma_lookup(struct drm_i915_gem_object *obj,
> struct i915_address_space *vm,
> const struct i915_ggtt_view *view)
> {
> @@ -278,7 +278,7 @@ i915_vma_instance(struct drm_i915_gem_object *obj,
> GEM_BUG_ON(!atomic_read(&vm->open));
>
> spin_lock(&obj->vma.lock);
> - vma = vma_lookup(obj, vm, view);
> + vma = i915_vma_lookup(obj, vm, view);
> spin_unlock(&obj->vma.lock);
>
> /* vma_create() will resolve the race if another creates the vma */
> --
> 2.30.0

--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch