On a related topic, any preference on whether to have an explicit "must_lock"
flag (what I posted), or derive the logic based on other params?
The helper I posted does:
if (range->must_lock &&
kvm_mmu_lock_and_check_handler(kvm, range, &locked))
goto out_unlock;
but it could be:
if (!IS_KVM_NULL_FN(range->on_lock) && !range->may_block &&
kvm_mmu_lock_and_check_handler(kvm, range, &locked))
goto out_unlock;
The generated code should be nearly identical on a modern compiler, so it's
purely a question of aesthetics. I slightly prefer the explicit "must_lock" to
avoid spreading out the logic too much, but it also feels a bit superfluous.