Re: [Outreachy kernel] [RFC PATCH] staging: unisys: visorhba: Convert module from IDR to XArray

From: Fabio M. De Francesco
Date: Mon Apr 26 2021 - 06:39:32 EST


On Monday, April 26, 2021 11:56:21 AM CEST Greg Kroah-Hartman wrote:
> On Mon, Apr 26, 2021 at 11:50:15AM +0200, Fabio M. De Francesco wrote:
> > Converted visorhba from IDR to XArray. The abstract data type XArray is
> > more memory-efficient, parallelisable and cache friendly. It takes
> > advantage of RCU to perform lookups without locking.
> >
> > Signed-off-by: Fabio M. De Francesco <fmdefrancesco@xxxxxxxxx>
> > ---
> >
> > .../staging/unisys/visorhba/visorhba_main.c | 107 +++++++-----------
> > 1 file changed, 44 insertions(+), 63 deletions(-)
> >
> > diff --git a/drivers/staging/unisys/visorhba/visorhba_main.c
> > b/drivers/staging/unisys/visorhba/visorhba_main.c index
4455d26f7c96..851e60ab0c46
> > 100644
> > --- a/drivers/staging/unisys/visorhba/visorhba_main.c
> > +++ b/drivers/staging/unisys/visorhba/visorhba_main.c
> > @@ -6,10 +6,10 @@
> >
> > #include <linux/debugfs.h>
> > #include <linux/kthread.h>
> >
> > -#include <linux/idr.h>
> >
> > #include <linux/module.h>
> > #include <linux/seq_file.h>
> > #include <linux/visorbus.h>
> >
> > +#include <linux/xarray.h>
> >
> > #include <scsi/scsi.h>
> > #include <scsi/scsi_host.h>
> > #include <scsi/scsi_cmnd.h>
> >
> > @@ -23,6 +23,8 @@
> >
> > #define MAX_PENDING_REQUESTS (MIN_NUMSIGNALS * 2)
> > #define VISORHBA_ERROR_COUNT 30
> >
> > +static DEFINE_XARRAY_ALLOC(xa_dtstr);
> > +
> >
> > static struct dentry *visorhba_debugfs_dir;
> >
> > /* GUIDS for HBA channel type supported by this driver */
> >
> > @@ -78,12 +80,6 @@ struct visorhba_devdata {
> >
> > unsigned int max_buff_len;
> > int devnum;
> > struct uiscmdrsp *cmdrsp;
> >
> > - /*
> > - * allows us to pass int handles back-and-forth between us and
> > - * iovm, instead of raw pointers
> > - */
> > - struct idr idr;
> > -
> >
> > struct dentry *debugfs_dir;
> > struct dentry *debugfs_info;
> >
> > };
> >
> > @@ -183,32 +179,16 @@ static struct uiscmdrsp
*get_scsipending_cmdrsp(struct
> > visorhba_devdata *ddata,>
> > }
> >
> > /*
> >
> > - * simple_idr_get - Associate a provided pointer with an int value
> > - * 1 <= value <= INT_MAX, and return this int value;
> > - * the pointer value can be obtained later by passing
> > - * this int value to idr_find()
> > - * @idrtable: The data object maintaining the pointer<-->int mappings
> > - * @p: The pointer value to be remembered
> > - * @lock: A spinlock used when exclusive access to idrtable is needed
> > - *
> > - * Return: The id number mapped to pointer 'p', 0 on failure
> > + * simple_xa_dtstr_get - Store a pointer to xa_dtstr xarray
> > + * @id: Pointer to ID
> > + * @entry: New entry
> >
> > */
> >
> > -static unsigned int simple_idr_get(struct idr *idrtable, void *p,
> > - spinlock_t *lock)
> > +static int simple_xa_dtstr_get(u32 *id, void *entry)
>
> What are you trying to really "get" here? We shouldn't name the
> function based on the data type being used. All we want is some sort of
> "token" or hash or something else? It's hard to tell...
>
Sorry, I am so lazy that I just substituted the _idr_ in the old name with
_xa_dtstr_. Perhaps simple_entry_get() would be better. it deserves a v2.
>
> > {
> >
> > - int id;
> > - unsigned long flags;
> > + int ret = xa_alloc_irq(&xa_dtstr, id, entry, xa_limit_32b,
GFP_NOWAIT);
> > + /* TODO: check for and manage errors */
>
> That's a nice TODO, which means we really should not be considering this
> patch to be merged, right?
>
Right, lazy again :)

The fact is that I was just interested in conversion from IDR to XArray
because this would be the main subject of the project I applied for the DRM
subsystem. Therefore, where I didn't find proper error checking and management
in the old code, I simply wrote some TODO.

I suppose that some more knowledge of both Linux device drivers programming
and of that specific driver is needed to do proper management of errors in
order to unwind what is already done by the code and leave everything in a
consistent state. I'd left that work to Unisys developers, if you don't mind.
I'd prefer to simply remove those TODO from where I placed them. I hope that
you agree with me.

Thanks for your review,

Fabio
>
> thanks,
>
> greg k-h