Re: [PATCH v4 1/2] PCI: Add support for a function level reset based on _RST method

From: Shanker R Donthineni
Date: Fri Apr 30 2021 - 15:06:43 EST


Hi Alex,

On 4/30/21 1:39 PM, Alex Williamson wrote:
> External email: Use caution opening links or attachments
>
>
> On Wed, 28 Apr 2021 19:49:06 -0500
> Shanker Donthineni <sdonthineni@xxxxxxxxxx> wrote:
>
>> The _RST is a standard method specified in the ACPI specification. It
>> provides a function level reset when it is described in the acpi_device
>> context associated with PCI-device.
>>
>> Implement a new reset function pci_dev_acpi_reset() for probing RST
>> method and execute if it is defined in the firmware. The ACPI binding
>> information is available only after calling device_add(), so move
>> pci_init_reset_methods() to end of the pci_device_add().
>>
>> The default priority of the acpi reset is set to below device-specific
>> and above hardware resets.
>>
>> Signed-off-by: Shanker Donthineni <sdonthineni@xxxxxxxxxx>
>> ---
>> changes since v2:
>> - fix typo in the commit text
>> changes since v2:
>> - rebase patch on top of https://lore.kernel.org/linux-pci/20210409192324.30080-1-ameynarkhede03@xxxxxxxxx/
>>
>> drivers/pci/pci.c | 30 ++++++++++++++++++++++++++++++
>> drivers/pci/probe.c | 2 +-
>> include/linux/pci.h | 2 +-
>> 3 files changed, 32 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
>> index 664cf2d358d6..510f9224a3b0 100644
>> --- a/drivers/pci/pci.c
>> +++ b/drivers/pci/pci.c
>> @@ -5076,6 +5076,35 @@ static void pci_dev_restore(struct pci_dev *dev)
>> err_handler->reset_done(dev);
>> }
>>
>> +/**
>> + * pci_dev_acpi_reset - do a function level reset using _RST method
>> + * @dev: device to reset
>> + * @probe: check if _RST method is included in the acpi_device context.
>> + */
>> +static int pci_dev_acpi_reset(struct pci_dev *dev, int probe)
>> +{
>> +#ifdef CONFIG_ACPI
>> + acpi_handle handle = ACPI_HANDLE(&dev->dev);
>> +
>> + /* Return -ENOTTY if _RST method is not included in the dev context */
>> + if (!handle || !acpi_has_method(handle, "_RST"))
>> + return -ENOTTY;
>> +
>> + /* Return 0 for probe phase indicating that we can reset this device */
>> + if (probe)
>> + return 0;
>> +
>> + /* Invoke _RST() method to perform a function level reset */
>> + if (ACPI_FAILURE(acpi_evaluate_object(handle, "_RST", NULL, NULL))) {
>> + pci_warn(dev, "Failed to reset the device\n");
>> + return -EINVAL;
>> + }
>> + return 0;
>> +#else
>> + return -ENOTTY;
>> +#endif
>> +}
>> +
>> /*
>> * The ordering for functions in pci_reset_fn_methods
>> * is required for reset_methods byte array defined
>> @@ -5083,6 +5112,7 @@ static void pci_dev_restore(struct pci_dev *dev)
>> */
>> const struct pci_reset_fn_method pci_reset_fn_methods[] = {
>> { .reset_fn = &pci_dev_specific_reset, .name = "device_specific" },
>> + { .reset_fn = &pci_dev_acpi_reset, .name = "acpi_reset" },
> Would it make sense to name this "acpi_rst" after the method name?
> Otherwise "_reset" is a bit redundant to the sysfs attribute, we could
> simply name it "acpi" to indicate an ACPI based reset. Thanks,
>
Thanks,  I will change to "{ .reset_fn = &pci_dev_acpi_reset, .name = "acpi" }"