Re: [PATCH 1/2] selftests/sgx: Rename 'eenter' and 'sgx_call_vdso'
From: Jarkko Sakkinen
Date: Wed May 05 2021 - 21:40:41 EST
On Thu, May 06, 2021 at 04:31:59AM +0300, Jarkko Sakkinen wrote:
> Rename 'eenter' as 'sgx_enter_enclave', and 'sgx_call_vdso' as
> 'sgx_enter_enclave_unclobbered', in order to better self-describe the
> meaning and purpose of the symbols.
> Signed-off-by: Jarkko Sakkinen <jarkko@xxxxxxxxxx>
Nit: I think actually t these would be clearer names:
- eenter -> sgx_enter_enclave_vdso
- sgx_call_vdso -> sgx_enter_enclave