Re: [PATCH V3 1/4] dt-bindings: power: Add defines for i.MX8MM BLK-CTL power domains

From: Frieder Schrempf
Date: Thu May 06 2021 - 03:16:02 EST


On 06.05.21 06:15, Peng Fan (OSS) wrote:
> From: Peng Fan <peng.fan@xxxxxxx>
>
> Adding the defines for i.MX8MM BLK-CTL power domains.
>
> Signed-off-by: Peng Fan <peng.fan@xxxxxxx>
> ---
> include/dt-bindings/power/imx8mm-power.h | 11 +++++++++++
> 1 file changed, 11 insertions(+)
>
> diff --git a/include/dt-bindings/power/imx8mm-power.h b/include/dt-bindings/power/imx8mm-power.h
> index fc9c2e16aadc..510e383d1953 100644
> --- a/include/dt-bindings/power/imx8mm-power.h
> +++ b/include/dt-bindings/power/imx8mm-power.h
> @@ -19,4 +19,15 @@
> #define IMX8MM_POWER_DOMAIN_DISPMIX 10
> #define IMX8MM_POWER_DOMAIN_MIPI 11
>
> +#define IMX8MM_BLK_CTL_G2_PD 0
> +#define IMX8MM_BLK_CTL_G1_PD 1
> +#define IMX8MM_BLK_CTL_H1_PD 2
> +#define IMX8MM_BLK_CTL_MAX_PD 3

I think it would be good to have "VPU" somewhere in these defines. Like IMX8MM_BLK_CTL_VPU_*. And here you have the *_PD suffix, but for dispmix below you don't have it. I think you should either remove the suffix here, or add it below, while I would go for the former.

> +
> +#define IMX8MM_BLK_CTL_DISPMIX_CSI_BRIDGE 0
> +#define IMX8MM_BLK_CTL_DISPMIX_LCDIF 1
> +#define IMX8MM_BLK_CTL_DISPMIX_MIPI_DSI 2
> +#define IMX8MM_BLK_CTL_DISPMIX_MIPI_CSI 3
> +#define IMX8MM_BLK_CTL_DISPMIX_MAX_PD 4
> +
> #endif
>