Re: [PATCH 4/6] x86/irq: merge common code in DEFINE_IDTENTRY_SYSVEC[_SIMPLE]

From: H. Peter Anvin
Date: Tue May 11 2021 - 13:44:45 EST


On 5/11/21 7:22 AM, Thomas Gleixner wrote:

That's not really making the code more readable. Something like the
below perhaps?

#define IDTENTRY_INVOKE_SYSVEC(func, regs, raw) \
do { \
irqentry_state_t state = irqentry_enter(regs); \
\
instrumentation_begin(); \
kvm_set_cpu_l1tf_flush_l1d(); \
if (raw) { \
__irq_enter_raw(); \
func(regs); \
__irq_exit_raw(); \
} else { \
run_sysvec_on_irqstack_cond(func, regs); \
} \
instrumentation_end(); \
irqentry_exit(regs, state); \
} while (0) \


Digging more into it, it looks like a *lot* of the macros in <asm/irq_stack.h> and <asm/idtentry.h> can be replaced with inlines without any change in functionality or generated code.

-hpa