[PATCH] driver core: replace open-coded device_lock_assert()

From: Julian Wiedmann
Date: Wed May 12 2021 - 10:11:14 EST


Using the right wrapper makes it easier to associate this assert
statement with the device_[un]lock() helpers.

Signed-off-by: Julian Wiedmann <jwi@xxxxxxxxxxxxx>
---
drivers/base/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/base/core.c b/drivers/base/core.c
index 4a8bf8cda52b..bfa3536d48df 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -3437,7 +3437,7 @@ bool kill_device(struct device *dev)
* to run while we are tearing out the bus/class/sysfs from
* underneath the device.
*/
- lockdep_assert_held(&dev->mutex);
+ device_lock_assert(dev);

if (dev->p->dead)
return false;
--
2.25.1