Re: [PATCH 2/3] riscv: Fixup PAGE_UP in asm/page.h
From: Christoph Hellwig
Date: Tue May 25 2021 - 05:35:38 EST
On Tue, May 25, 2021 at 05:28:21PM +0800, Guo Ren wrote:
> On Tue, May 25, 2021 at 2:34 PM Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote:
> > On Mon, May 24, 2021 at 06:51:07AM +0000, guoren@xxxxxxxxxx wrote:
> > > From: Guo Ren <guoren@xxxxxxxxxxxxxxxxx>
> > >
> > > Current PAGE_UP implementation is wrong. PAGE_UP(0) should be
> > > 0x1000, but current implementation will give out 0.
> > >
> > > Although the current PAGE_UP isn't used, it will soon be used in
> > > tlb_flush optimization.
> > Nak. Please just remove the PAGE_UP/PAGE_DOWN macros just like they
> > have been removed from other architectures long ago and use the
> > generic DIV_ROUND_UP macro for your new code like everyone else.
> This patch has been dropped because it's wrong, ref Anup's reply.
> Remove PAGE_UP/DOWN is okay for me. How about:
> static inline void local_flush_tlb_range_asid(unsigned long start,
> unsigned long size,
> unsigned long asid)
> - unsigned long page_add = PAGE_DOWN(start);
> - unsigned long page_end = PAGE_UP(start + size);
> + unsigned long page_add = _ALIGN_DOWN(start, PAGE_SIZE);
> + unsigned long page_end = _ALIGN_UP(start + size, PAGE_SIZE);
> _ALIGN_XXX are also defined in arch/riscv/include/asm/page.h.
And these also are leftovers from days gone by and should be removed.
I think this should simply be:
unsigned long page_add = start & PAGE_MASK;
unsigned long page_end = PAGE_ALIGN(start + size);
(and page_add is a pretty horrible name as well..)