[PATCH 1/1] rapidio: use DEVICE_ATTR_RO macro

From: Zhen Lei
Date: Wed Jun 02 2021 - 03:52:48 EST


Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.

Signed-off-by: Zhen Lei <thunder.leizhen@xxxxxxxxxx>
---
drivers/rapidio/switches/idt_gen2.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/rapidio/switches/idt_gen2.c b/drivers/rapidio/switches/idt_gen2.c
index 8a89bba17d39900..0fb91e6c691f456 100644
--- a/drivers/rapidio/switches/idt_gen2.c
+++ b/drivers/rapidio/switches/idt_gen2.c
@@ -366,7 +366,7 @@ idtg2_em_handler(struct rio_dev *rdev, u8 portnum)
}

static ssize_t
-idtg2_show_errlog(struct device *dev, struct device_attribute *attr, char *buf)
+errlog_show(struct device *dev, struct device_attribute *attr, char *buf)
{
struct rio_dev *rdev = to_rio_dev(dev);
ssize_t len = 0;
@@ -384,7 +384,7 @@ idtg2_show_errlog(struct device *dev, struct device_attribute *attr, char *buf)
return len;
}

-static DEVICE_ATTR(errlog, S_IRUGO, idtg2_show_errlog, NULL);
+static DEVICE_ATTR_RO(errlog);

static int idtg2_sysfs(struct rio_dev *rdev, bool create)
{
--
2.26.0.106.g9fadedd