Re: [PATCH v11 15/33] mm/filemap: Add folio_offset() and folio_file_offset()

From: David Howells
Date: Wed Jun 16 2021 - 06:05:35 EST

Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx> wrote:

> These are just wrappers around their page counterpart. No change to
> generated code.
> Signed-off-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx>
> Reviewed-by: Christoph Hellwig <hch@xxxxxx>
> Acked-by: Jeff Layton <jlayton@xxxxxxxxxx>
> Acked-by: Kirill A. Shutemov <kirill.shutemov@xxxxxxxxxxxxxxx>
> Acked-by: Vlastimil Babka <vbabka@xxxxxxx>
> Reviewed-by: William Kucharski <william.kucharski@xxxxxxxxxx>

I wonder if folio_fpos() would be better a better name than folio_offset().
"Offset" is a bit overloaded.

Reviewed-by: David Howells <dhowells@xxxxxxxxxx>