Re: [PATCH v1 1/1] spi: Remove unneeded parentheses in spi_map_buf()

From: Mark Brown
Date: Mon Jun 21 2021 - 06:39:48 EST


On Sat, Jun 19, 2021 at 02:15:26PM +0300, Andy Shevchenko wrote:
> The boolean expression to get kmap_buf is hard to read due to
> too many unneeded parentheses. Remove them for good.

> - const bool kmap_buf = ((unsigned long)buf >= PKMAP_BASE &&
> - (unsigned long)buf < (PKMAP_BASE +
> - (LAST_PKMAP * PAGE_SIZE)));
> + const bool kmap_buf = (unsigned long)buf >= PKMAP_BASE &&
> + (unsigned long)buf < (PKMAP_BASE + LAST_PKMAP * PAGE_SIZE);

No, I think this makes things worse - to the extent there's an issue
here it's not excessive brackets.

Attachment: signature.asc
Description: PGP signature