Re: [PATCH v12] i2c: virtio: add a virtio i2c frontend driver

From: Jie Deng
Date: Sun Jul 04 2021 - 23:09:53 EST



On 2021/7/5 10:43, Viresh Kumar wrote:
On 02-07-21, 12:58, Andy Shevchenko wrote:
On Fri, Jul 02, 2021 at 04:46:47PM +0800, Jie Deng wrote:
+static int virtio_i2c_complete_reqs(struct virtqueue *vq,
+ struct virtio_i2c_req *reqs,
+ struct i2c_msg *msgs, int nr,
+ bool fail)
+{
+ struct virtio_i2c_req *req;
+ bool failed = fail;
Jie, you can actually get rid of this variable too. Jut rename fail to failed
and everything shall work as you want.

Sure.