On 05. 08. 21, 9:58, Jiri Slaby wrote:I will make the cleanup in v4.
Hi,
On 04. 08. 21, 4:54, Xianting Tian wrote:
@@ -933,6 +949,16 @@ struct hvc_struct *hvc_alloc(uint32_t vtermno, int data,
hp->outbuf_size = outbuf_size;
hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];
This deserves cleanup too. Why is "outbuf" not "char outbuf[0] __ALIGNED__" at the end of the structure? The allocation would be easier (using struct_size()) and this line would be gone completely.
thanks, it a good idea, I will change it in v4.
+ /*
+ * hvc_con_outbuf is guaranteed to be aligned at least to the
+ * size(N_OUTBUF) by kmalloc().
+ */
+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);
+ if (!hp->hvc_con_outbuf)
+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
Actually, why don't you make
char c[N_OUTBUF] __ALIGNED__;
part of struct hvc_struct directly?
BTW your 2 patches are still not threaded, that is hard to follow.
+
+ spin_lock_init(&hp->hvc_con_lock);
+
tty_port_init(&hp->port);
hp->port.ops = &hvc_port_ops;
thanks,