Re: [PATCH v2 1/4] staging: r8188eu: refactor rtw_is_cckrates_included()

From: Fabio M. De Francesco
Date: Mon Aug 16 2021 - 08:59:44 EST


On Monday, August 16, 2021 1:54:27 PM CEST Michael Straube wrote:
> Refactor function rtw_is_cckrates_included(). Improves readability
> and slightly reduces object file size.
>
> Signed-off-by: Michael Straube <straube.linux@xxxxxxxxx>
> ---
> v1 -> v2
> Refactored to more compact code as suggested by Joe Perches.
>
> drivers/staging/r8188eu/core/rtw_ieee80211.c | 9 ++++-----
> 1 file changed, 4 insertions(+), 5 deletions(-)
>

Thanks for redoing the series as suggested by Joe Perches.
This is a perfect case where conciseness and readability don't clash and
instead the former enhances the latter.

Nice work, although you chose to not take Joe's suggestion about making a
helper inline function. That would have been perfect, but I think it is a
minor issue. So...

Acked-by: Fabio M. De Francesco <fmdefrancesco@xxxxxxxxx>

Regards,

Fabio

P.S.: If I were you, I'd have provided a cover letter that would have helped
the readers to immediately understand the purpose of the entire series. I'm
not sure whether or not the above-mentioned cover is a strict requirement.

> diff --git a/drivers/staging/r8188eu/core/rtw_ieee80211.c
> b/drivers/staging/r8188eu/core/rtw_ieee80211.c index 0c7231cefdda..
964255a8c778 100644
> --- a/drivers/staging/r8188eu/core/rtw_ieee80211.c
> +++ b/drivers/staging/r8188eu/core/rtw_ieee80211.c
> @@ -70,14 +70,13 @@ int rtw_get_bit_value_from_ieee_value(u8 val)
>
> uint rtw_is_cckrates_included(u8 *rate)
> {
> - u32 i = 0;
> + u8 r;
>
> - while (rate[i] != 0) {
> - if ((((rate[i]) & 0x7f) == 2) || (((rate[i]) & 0x7f)
== 4) ||
> - (((rate[i]) & 0x7f) == 11) || (((rate[i]) & 0x7f)
== 22))
> + while ((r = *rate++ & 0x7f)) {
> + if (r == 2 || r == 4 || r == 11 || r == 22)
> return true;
> - i++;
> }
> +
> return false;
> }