Re: [PATCH] memstick: r592: Change the name of the 'pci_driver' structure to be consistent

From: Ulf Hansson
Date: Tue Aug 24 2021 - 10:57:34 EST


On Sat, 21 Aug 2021 at 23:17, Christophe JAILLET
<christophe.jaillet@xxxxxxxxxx> wrote:
>
> This driver is all about r592.
>
> Axe the reference to r852 in the 'pci_driver' structure name. This is
> likely a copy/paste typo left as is when the driver has been created.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@xxxxxxxxxx>

Applied for next, thanks!

Kind regards
Uffe


> ---
> drivers/memstick/host/r592.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/memstick/host/r592.c b/drivers/memstick/host/r592.c
> index 7ed984360349..e79a0218c492 100644
> --- a/drivers/memstick/host/r592.c
> +++ b/drivers/memstick/host/r592.c
> @@ -876,7 +876,7 @@ static SIMPLE_DEV_PM_OPS(r592_pm_ops, r592_suspend, r592_resume);
>
> MODULE_DEVICE_TABLE(pci, r592_pci_id_tbl);
>
> -static struct pci_driver r852_pci_driver = {
> +static struct pci_driver r592_pci_driver = {
> .name = DRV_NAME,
> .id_table = r592_pci_id_tbl,
> .probe = r592_probe,
> @@ -884,7 +884,7 @@ static struct pci_driver r852_pci_driver = {
> .driver.pm = &r592_pm_ops,
> };
>
> -module_pci_driver(r852_pci_driver);
> +module_pci_driver(r592_pci_driver);
>
> module_param_named(enable_dma, r592_enable_dma, bool, S_IRUGO);
> MODULE_PARM_DESC(enable_dma, "Enable usage of the DMA (default)");
> --
> 2.30.2
>