Re: [PATCH] serial: 8250_pci: Prefer struct_size over open coded arithmetic

From: Andy Shevchenko
Date: Sun Sep 05 2021 - 12:14:35 EST


On Sun, Sep 5, 2021 at 6:58 PM Len Baker <len.baker@xxxxxxx> wrote:
>
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + size * count" in the kzalloc() function.

Makes sense
Reviewed-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx>

> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@xxxxxxx>
> ---
> drivers/tty/serial/8250/8250_pci.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/tty/serial/8250/8250_pci.c b/drivers/tty/serial/8250/8250_pci.c
> index a808c283883e..b97ade35d4a3 100644
> --- a/drivers/tty/serial/8250/8250_pci.c
> +++ b/drivers/tty/serial/8250/8250_pci.c
> @@ -3981,9 +3981,7 @@ pciserial_init_ports(struct pci_dev *dev, const struct pciserial_board *board)
> nr_ports = rc;
> }
>
> - priv = kzalloc(sizeof(struct serial_private) +
> - sizeof(unsigned int) * nr_ports,
> - GFP_KERNEL);
> + priv = kzalloc(struct_size(priv, line, nr_ports), GFP_KERNEL);
> if (!priv) {
> priv = ERR_PTR(-ENOMEM);
> goto err_deinit;
> --
> 2.25.1
>


--
With Best Regards,
Andy Shevchenko