Re: [PATCH] platform/x86: thinkpad_acpi: Prefer struct_size over open coded arithmetic

From: Kees Cook
Date: Mon Sep 20 2021 - 02:00:57 EST


On Sat, Sep 18, 2021 at 05:05:00PM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, switch to flexible array member in the struct attribute_set_obj and
> refactor the code accordingly to use the struct_size() helper instead of
> the argument "size + count * size" in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@xxxxxxx>
> ---
> drivers/platform/x86/thinkpad_acpi.c | 8 +++-----
> 1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/platform/x86/thinkpad_acpi.c b/drivers/platform/x86/thinkpad_acpi.c
> index 50ff04c84650..ed0b01ead796 100644
> --- a/drivers/platform/x86/thinkpad_acpi.c
> +++ b/drivers/platform/x86/thinkpad_acpi.c
> @@ -1008,7 +1008,7 @@ struct attribute_set {
>
> struct attribute_set_obj {
> struct attribute_set s;
> - struct attribute *a;
> + struct attribute *a[];
> } __attribute__((packed));

Whoa. I have so many questions... :)

>
> static struct attribute_set *create_attr_set(unsigned int max_members,
> @@ -1020,13 +1020,11 @@ static struct attribute_set *create_attr_set(unsigned int max_members,
> return NULL;
>
> /* Allocates space for implicit NULL at the end too */
> - sobj = kzalloc(sizeof(struct attribute_set_obj) +
> - max_members * sizeof(struct attribute *),
> - GFP_KERNEL);
> + sobj = kzalloc(struct_size(sobj, a, max_members + 1), GFP_KERNEL);

Whoa, this needs a lot more detail in the changelog if this is actually
correct. The original code doesn't seem to match the comment? (Where is
the +1?) So is this also a bug-fix?

(I see the caller uses +2? Why? It seems to be using each of hotkey_attributes,
plus 1 more attr, plus a final NULL?)

> if (!sobj)
> return NULL;
> sobj->s.max_members = max_members;
> - sobj->s.group.attrs = &sobj->a;
> + sobj->s.group.attrs = sobj->a;
> sobj->s.group.name = name;

The caller also never sets a name?

Why is struct attribute_set_obj marked as __packed?

>
> return &sobj->s;
> --
> 2.25.1
>

--
Kees Cook