Re: [PATCH] dmaengine: pxa_dma: Prefer struct_size over open coded arithmetic

From: Gustavo A. R. Silva
Date: Mon Sep 20 2021 - 20:21:56 EST




On 9/18/21 05:40, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@xxxxxxx>

Reviewed-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx>

> ---
> drivers/dma/pxa_dma.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/dma/pxa_dma.c b/drivers/dma/pxa_dma.c
> index 4a2a796e348c..52d04641e361 100644
> --- a/drivers/dma/pxa_dma.c
> +++ b/drivers/dma/pxa_dma.c
> @@ -742,8 +742,7 @@ pxad_alloc_desc(struct pxad_chan *chan, unsigned int nb_hw_desc)
> dma_addr_t dma;
> int i;
>
> - sw_desc = kzalloc(sizeof(*sw_desc) +
> - nb_hw_desc * sizeof(struct pxad_desc_hw *),
> + sw_desc = kzalloc(struct_size(sw_desc, hw_desc, nb_hw_desc),
> GFP_NOWAIT);
> if (!sw_desc)
> return NULL;
> --
> 2.25.1
>