Re: [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic

From: Kees Cook
Date: Tue Sep 21 2021 - 00:07:06 EST


On Sun, Sep 05, 2021 at 09:49:36AM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, refactor the code a bit to use the purpose specific kcalloc()
> function instead of the argument size * count in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@xxxxxxx>
> ---
> .../net/ethernet/mellanox/mlx5/core/steering/dr_action.c | 8 ++++++--
> 1 file changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> index 6475ba35cf6b..e8957dad3bb1 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> @@ -716,6 +716,7 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
> struct mlx5dr_action *action;
> bool reformat_req = false;
> u32 num_of_ref = 0;
> + u32 ref_act_cnt;
> int ret;
> int i;
>
> @@ -724,11 +725,14 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
> return NULL;
> }
>
> - hw_dests = kzalloc(sizeof(*hw_dests) * num_of_dests, GFP_KERNEL);
> + hw_dests = kcalloc(num_of_dests, sizeof(*hw_dests), GFP_KERNEL);
> if (!hw_dests)
> return NULL;
>
> - ref_actions = kzalloc(sizeof(*ref_actions) * num_of_dests * 2, GFP_KERNEL);
> + if (unlikely(check_mul_overflow(num_of_dests, 2u, &ref_act_cnt)))
> + goto free_hw_dests;
> +
> + ref_actions = kcalloc(ref_act_cnt, sizeof(*ref_actions), GFP_KERNEL);

In the future, consider array3_size(), but this is fine too. :)

-Kees

> if (!ref_actions)
> goto free_hw_dests;
>
> --
> 2.25.1
>

--
Kees Cook