[PATCH RESEND 0/2] Use generic code for randomization of virtual address of x86

From: sxwjean
Date: Tue Sep 21 2021 - 10:34:57 EST


From: Xiongwei Song <sxwjean@xxxxxxxxx>

Hello,

The two patches are to use generic code for randomization of virtual
address of x86. Since the basic code logic of x86 is same as generic
code, so no need to implement these functions on x86, please see the
details in comments of patch 2.

Please review it.

Why resend?
Because I missed email addresses for patch 1 and 2, so resend the patches.
Sorry for the inconvenience.

Xiongwei Song (2):
x86: Rename TIF_ADDR32 to TIF_32BIT
x86/mm: Randomize va with generic arch_pick_mmap_layout()

arch/x86/Kconfig | 2 +-
arch/x86/include/asm/compat.h | 7 +-
arch/x86/include/asm/elf.h | 2 +-
arch/x86/include/asm/page_64_types.h | 6 +-
arch/x86/include/asm/processor.h | 4 +-
arch/x86/include/asm/thread_info.h | 4 +-
arch/x86/kernel/process.c | 5 --
arch/x86/kernel/process_64.c | 4 +-
arch/x86/mm/mmap.c | 112 ---------------------------
include/linux/compat.h | 4 +
mm/util.c | 18 ++++-
11 files changed, 37 insertions(+), 131 deletions(-)

--
2.30.2