Re: [PATCH] Urgent bug fix causing Apple SSDs to not work.

From: Aditya Garg
Date: Mon Sep 27 2021 - 00:38:31 EST

I tried Orlando Chamberlain's patch on 5.14.7 but still the SSD is not being recognised.

From: Orlando Chamberlain <redecorating@xxxxxxxxxxxxxx>
Sent: Sunday, September 26, 2021 8:44 AM
To: Aditya Garg; sagi@xxxxxxxxxxx; kbusch@xxxxxxxxxx
Cc: torvalds@xxxxxxxxxxxxxxxxxxxx; axboe@xxxxxx; hch@xxxxxx; linux-nvme@xxxxxxxxxxxxxxxxxxx;; chaitanya.kulkarni@xxxxxxx; akpm@xxxxxxxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; trivial@xxxxxxxxxx
Subject: Re: [PATCH] Urgent bug fix causing Apple SSDs to not work.

On 26/9/21 18:07, Aditya Garg wrote:
> I checked out the proposal sent by Orlando Chamberlain to replace
> NVME_QUIRK_SHARED_TAGS , by NVME_QUIRK_SHARED_TAGS | given in the patch on
> <>.
> The , still causes panics to the T2 as described before. In the case of |, the
> kernel boots correctly without panicking the T2, but in case we are having Linux
> on an External Drive, which is my case, then the internal SSD doesn't seem to be
> recognised at all. I've tested the patch on 5.14.7. A screenshot of the GNOME
> Disks utility has been attached along with this mail.

I had some issues with the patch not applying automatically as I mixed up tabs and spaces,
(due to me copying stuff directly out of vim), so I had issues with getting patches to apply
automatically. I've checked that this file
applies correctly for me (and github ci), so can you see if it still doesn't work with that?