Re: [PATCH v17 05/15] arm64: kexec: skip relocation code for inplace kexec
From: Pasha Tatashin
Date: Wed Sep 29 2021 - 22:45:05 EST
Hi Will,
> > + cpu_install_idmap();
> > + restart = (void *)__pa_symbol(function_nocfi(__cpu_soft_restart));
> > + restart(is_hyp_nvhe(), kimage->start, kimage->arch.dtb_mem,
> > + 0, 0);
>
> Why can't you call:
>
> cpu_soft_restart(kimage->start, kimage->arch.dtb_mem, 0, 0);
>
> here instead of open-coding it?
This is part of a cleanup to remove cpu_soft_restart() wrapper and the
header file that contains it. The wrapper is simple enough and has
only one call site. It makes more sense to do what is needed directly
from machine_kexec().
Pasha