Re: [PATCH 2/6] MM: improve documentation for __GFP_NOFAIL

From: Vlastimil Babka
Date: Tue Oct 05 2021 - 05:21:01 EST


On 9/17/21 04:56, NeilBrown wrote:
> __GFP_NOFAIL is documented both in gfp.h and memory-allocation.rst.
> The details are not entirely consistent.
>
> This patch ensures both places state that:
> - there is a risk of deadlock with reclaim/writeback/oom-kill
> - it should only be used when there is no real alternative
> - it is preferable to an endless loop
> - it is strongly discourages for costly-order allocations.
>
> Signed-off-by: NeilBrown <neilb@xxxxxxx>

Acked-by: Vlastimil Babka <vbabka@xxxxxxx>

Nit below:

> diff --git a/include/linux/gfp.h b/include/linux/gfp.h
> index 55b2ec1f965a..1d2a89e20b8b 100644
> --- a/include/linux/gfp.h
> +++ b/include/linux/gfp.h
> @@ -209,7 +209,11 @@ struct vm_area_struct;
> * used only when there is no reasonable failure policy) but it is
> * definitely preferable to use the flag rather than opencode endless
> * loop around allocator.
> - * Using this flag for costly allocations is _highly_ discouraged.
> + * Use of this flag may lead to deadlocks if locks are held which would
> + * be needed for memory reclaim, write-back, or the timely exit of a
> + * process killed by the OOM-killer. Dropping any locks not absolutely
> + * needed is advisable before requesting a %__GFP_NOFAIL allocate.
> + * Using this flag for costly allocations (order>1) is _highly_ discouraged.

We define costly as 3, not 1. But sure it's best to avoid even order>0 for
__GFP_NOFAIL. Advising order>1 seems arbitrary though?

> */
> #define __GFP_IO ((__force gfp_t)___GFP_IO)
> #define __GFP_FS ((__force gfp_t)___GFP_FS)
>
>
>