Re: [PATCH v1 1/2] serial: 8250_lpss: Extract dw8250_do_set_termios() for common use

From: Greg Kroah-Hartman
Date: Tue Oct 05 2021 - 08:53:32 EST


On Sat, Oct 02, 2021 at 09:51:40PM +0300, Andy Shevchenko wrote:
> Some of the code currently used in dw8250_set_termios(), byt_set_termios()
> may be reused by other methods in the future. Extract it to a common helper
> function.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
> drivers/tty/serial/8250/8250_dw.c | 8 ++------
> drivers/tty/serial/8250/8250_dwlib.c | 10 ++++++++++
> drivers/tty/serial/8250/8250_dwlib.h | 1 +
> drivers/tty/serial/8250/8250_lpss.c | 6 +-----
> 4 files changed, 14 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/tty/serial/8250/8250_dw.c b/drivers/tty/serial/8250/8250_dw.c
> index a3a0154da567..e3c90c9e2448 100644
> --- a/drivers/tty/serial/8250/8250_dw.c
> +++ b/drivers/tty/serial/8250/8250_dw.c
> @@ -338,7 +338,7 @@ static void dw8250_set_termios(struct uart_port *p, struct ktermios *termios,
> rate = clk_round_rate(d->clk, newrate);
> if (rate > 0) {
> /*
> - * Premilinary set the uartclk to the new clock rate so the
> + * Preliminary set the uartclk to the new clock rate so the

Different change, not mentioned in the changelog, please make this a
separate patch.

thanks,

greg k-h