Re: [PATCH 1/6] block: cache bdev in struct file for raw bdev IO

From: Pavel Begunkov
Date: Wed Oct 13 2021 - 04:46:14 EST


On 10/11/21 09:26, Christoph Hellwig wrote:
On Sat, Oct 09, 2021 at 10:33:17AM -0600, Jens Axboe wrote:
+static inline struct block_device *blkdev_get_bdev(struct file *file)
+{
+ return file->private_data;
+}

Get rid of this and just use bdev = file->private_data where
appropriate. Easier to read, we don't need to hide this in a function.

100% agreed.

The reasoning is as always, it's much easier to change if we change
what we store there. I don't agree, but don't care enough to stay
on the point, will resend with the change

--
Pavel Begunkov