Re: [PATCH 0/4] ucounts: misc cleanups

From: Yu Zhao
Date: Mon Oct 18 2021 - 18:29:32 EST


On Mon, Oct 18, 2021 at 11:55 AM Eric W. Biederman
<ebiederm@xxxxxxxxxxxx> wrote:
>
>
> The following changes are a set of miscellaneous fixes that makes
> the ucount code a little bit easier to read. There are all things
> that I ran into while helping hunt the crazy reference count
> bug.
>
> I am aiming these at the next merge window and 5.16 rather than bug
> fixes to get into the current 5.15.
>
> Eric W. Biederman (4):
> ucounts: In set_cred_ucounts assume new->ucounts is non-NULL
> ucounts: Remove unnecessary test for NULL ucount in get_ucounts
> ucounts: Add get_ucounts_or_wrap for clarity
> ucounts: Use atomic_long_sub_return for clarity
>
> kernel/cred.c | 5 ++---
> kernel/ucount.c | 20 +++++++++++++-------
> 2 files changed, 15 insertions(+), 10 deletions(-)

Thanks for the cleanups. Tested the whole series on the latest 5.15-rc6.

Tested-by: Yu Zhao <yuzhao@xxxxxxxxxx>