Re: [PATCH] irqchip/irq-csky-mpintc: Fixup mask/unmask un-implementation

From: Marc Zyngier
Date: Mon Oct 25 2021 - 06:34:08 EST


On Mon, 25 Oct 2021 10:12:19 +0100,
guoren@xxxxxxxxxx wrote:
>
> From: Guo Ren <guoren@xxxxxxxxxxxxxxxxx>
>
> The mask/unmask must be implemented, and enable/disable supplement
> them if the HW requires something different at startup time. When
> irq source is disabled by mask, mpintc could complete irq normally.
>
> So just replace the with mask/unmask function.
>
> Tested-by: Guo Ren <guoren@xxxxxxxxxxxxxxxxx>

This only makes sense if tested by a third party. It is assumed that
the author of a patch has tested it.

> Signed-off-by: Guo Ren <guoren@xxxxxxxxxxxxxxxxx>
> Cc: Marc Zyngier <marc.zyngier@xxxxxxx>

This hasn't been my email address for over two years now. I'm sure my
ex manager is happy to hear from you, but I doubt he'll bother replying.

> ---
> drivers/irqchip/irq-csky-mpintc.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/irqchip/irq-csky-mpintc.c b/drivers/irqchip/irq-csky-mpintc.c
> index a1534edef7fa..f169600dbde6 100644
> --- a/drivers/irqchip/irq-csky-mpintc.c
> +++ b/drivers/irqchip/irq-csky-mpintc.c
> @@ -164,8 +164,8 @@ static int csky_irq_set_affinity(struct irq_data *d,
> static struct irq_chip csky_irq_chip = {
> .name = "C-SKY SMP Intc",
> .irq_eoi = csky_mpintc_eoi,
> - .irq_enable = csky_mpintc_enable,
> - .irq_disable = csky_mpintc_disable,
> + .irq_unmask = csky_mpintc_enable,
> + .irq_mask = csky_mpintc_disable,
> .irq_set_type = csky_mpintc_set_type,
> #ifdef CONFIG_SMP
> .irq_set_affinity = csky_irq_set_affinity,

Please rename the functions to match the fields they are assigned to.

Thanks,

M.

--
Without deviation from the norm, progress is not possible.