[PATCH] lib/mpi: use swap() to make code cleaner

From: Yang Guang
Date: Wed Oct 27 2021 - 20:34:11 EST


Using swap() make it more readable.

Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
Signed-off-by: Yang Guang <yang.guang5@xxxxxxxxxx>
---
lib/mpi/ec.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/lib/mpi/ec.c b/lib/mpi/ec.c
index 40f5908e57a4..a2f5694425ee 100644
--- a/lib/mpi/ec.c
+++ b/lib/mpi/ec.c
@@ -1282,14 +1282,12 @@ void mpi_ec_mul_point(MPI_POINT result,
sum = &p2_;

for (j = nbits-1; j >= 0; j--) {
- MPI_POINT t;
-
sw = mpi_test_bit(scalar, j);
point_swap_cond(q1, q2, sw, ctx);
montgomery_ladder(prd, sum, q1, q2, point->x, ctx);
point_swap_cond(prd, sum, sw, ctx);
- t = q1; q1 = prd; prd = t;
- t = q2; q2 = sum; sum = t;
+ swap(q1, prd);
+ swap(q2, sum);
}

mpi_clear(result->y);
--
2.30.2