[PATCH] gcc-plugins: use swap() to make code cleaner

From: Yang Guang
Date: Wed Oct 27 2021 - 20:35:38 EST


Using swap() make it more readable.

Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
Signed-off-by: Yang Guang <yang.guang5@xxxxxxxxxx>
---
scripts/gcc-plugins/randomize_layout_plugin.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/scripts/gcc-plugins/randomize_layout_plugin.c b/scripts/gcc-plugins/randomize_layout_plugin.c
index 334741a31d0a..feee5ba8fa2b 100644
--- a/scripts/gcc-plugins/randomize_layout_plugin.c
+++ b/scripts/gcc-plugins/randomize_layout_plugin.c
@@ -244,11 +244,8 @@ static void full_shuffle(tree *newtree, unsigned long length, ranctx *prng_state
unsigned long i, randnum;

for (i = length - 1; i > 0; i--) {
- tree tmp;
randnum = ranval(prng_state) % (i + 1);
- tmp = newtree[i];
- newtree[i] = newtree[randnum];
- newtree[randnum] = tmp;
+ swap(newtree[i], newtree[randnum]);
}
}

--
2.30.2