Re: [PATCH 03/15] irq: mips: simplify do_domain_IRQ()

From: Guenter Roeck
Date: Thu Oct 28 2021 - 13:07:37 EST


On Thu, Oct 21, 2021 at 07:02:24PM +0100, Mark Rutland wrote:
> There's no need fpr arch/mips's do_domain_IRQ() to open-code the NULL
> check performed by handle_irq_desc(), nor the resolution of the desc
> performed by generic_handle_domain_irq().
>
> Use generic_handle_domain_irq() directly, as this is functioanlly
> equivalent and clearer.
>
> There should be no functional change as a result of this patch.
>

Except for this compile error:

arch/mips/kernel/irq.c: In function 'do_domain_IRQ':
arch/mips/kernel/irq.c:114:26: error: unused variable 'desc' [-Werror=unused-variable]
114 | struct irq_desc *desc;

Guenter

> Signed-off-by: Mark Rutland <mark.rutland@xxxxxxx>
> Cc: Marc Zyngier <maz@xxxxxxxxxx>
> Cc: Thomas Bogendoerfer <tsbogend@xxxxxxxxxxxxxxxx>
> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
> ---
> arch/mips/kernel/irq.c | 6 +-----
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/arch/mips/kernel/irq.c b/arch/mips/kernel/irq.c
> index d20e002b3246..1fee96ef8059 100644
> --- a/arch/mips/kernel/irq.c
> +++ b/arch/mips/kernel/irq.c
> @@ -115,11 +115,7 @@ void __irq_entry do_domain_IRQ(struct irq_domain *domain, unsigned int hwirq)
>
> irq_enter();
> check_stack_overflow();
> -
> - desc = irq_resolve_mapping(domain, hwirq);
> - if (likely(desc))
> - handle_irq_desc(desc);
> -
> + generic_handle_domain_irq(domain, hwirq);
> irq_exit();
> }
> #endif
> --
> 2.11.0
>