Re: [PATCH] staging: r8188eu: os_dep: remove the goto statement

From: Saurav Girepunje
Date: Sun Oct 31 2021 - 15:17:56 EST




On 01/11/21 12:13 am, Pavel Skripkin wrote:
> On 10/31/21 21:10, Saurav Girepunje wrote:
>> Remove the goto statement from rtw_init_drv_sw(). In this function goto
>> can be replace by return statement. As on goto label exit, function
>> only return it is not performing any cleanup. Avoiding goto will
>> improve the function readability.
>>
>> Signed-off-by: Saurav Girepunje <saurav.girepunje@xxxxxxxxx>
>> ---
>>   drivers/staging/r8188eu/os_dep/os_intfs.c | 39 +++++++----------------
>>   1 file changed, 12 insertions(+), 27 deletions(-)
>>
>> diff --git a/drivers/staging/r8188eu/os_dep/os_intfs.c b/drivers/staging/r8188eu/os_dep/os_intfs.c
>> index 1418c9c4916c..4b409479108e 100644
>> --- a/drivers/staging/r8188eu/os_dep/os_intfs.c
>> +++ b/drivers/staging/r8188eu/os_dep/os_intfs.c
>> @@ -480,48 +480,34 @@ u8 rtw_init_drv_sw(struct adapter *padapter)
>>   {
>>       u8    ret8 = _SUCCESS;
>>
>
>
> Btw, this variable can be removed completely then. It's used only for:
>
> ret8 = rtw_init_default_value(padapter);
>
> with your patch applied, but rtw_init_default_value() always returns _SUCCESS.
>
I think rtw_init_default_value should return void. It's return value is not useful.
>
>> -exit:
>>      return ret8;
>>  }
>
>
> And just `return _SUCCESS;` here.
>
However rtw_init_drv_sw should return _SUCCESS here.
>
> With regards,
> Pavel Skripkin


Regards,
Saurav