[GIT PULL] ucount cleanups for v5.16

From: Eric W. Biederman
Date: Tue Nov 02 2021 - 15:01:14 EST



Linus,

Please pull the ucount-fixes-for-v5.16 branch from the git tree:

git://git.kernel.org/pub/scm/linux/kernel/git/ebiederm/user-namespace.git ucount-fixes-for-v5.16

HEAD: 32342701b4ba57a6fd77e8aca2f65f68c0fa1da6 ucounts: Use atomic_long_sub_return for clarity

While working on the ucount fixes a for v5.15 a number of cleanups
suggested themselves. Little things like not testing for NULL when a
pointer can not be NULL and wrapping atomic_add_negative with a more
descriptive name, so that people reading the code can more quickly
understand what is going on.

Eric W. Biederman (4):
ucounts: In set_cred_ucounts assume new->ucounts is non-NULL
ucounts: Remove unnecessary test for NULL ucount in get_ucounts
ucounts: Add get_ucounts_or_wrap for clarity
ucounts: Use atomic_long_sub_return for clarity

kernel/cred.c | 5 ++---
kernel/ucount.c | 20 +++++++++++++-------
2 files changed, 15 insertions(+), 10 deletions(-)

Eric