Re: [PATCH] media: use swap() to make code cleaner
From: Andy Shevchenko
Date: Thu Nov 04 2021 - 06:44:17 EST
On Wed, Nov 3, 2021 at 10:34 AM <davidcomponentone@xxxxxxxxx> wrote:
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
Same comments as per all your valuable contributions: just think more
about the code that you are dealing with!
> if (dev->fmt->uvswap) {
> - tmp = base2;
> - base2 = base3;
> - base3 = tmp;
> + swap(base2, base3);
> }
Have you run checkpatch? What did it say?
--
With Best Regards,
Andy Shevchenko