On Fri, 12 Nov 2021 11:09:13 +0100
Thomas Zimmermann <tzimmermann@xxxxxxx> wrote:
Hi
Am 12.11.21 um 10:39 schrieb Javier Martinez Canillas:
Hello Pekka,
On 11/12/21 09:56, Pekka Paalanen wrote:
[snip]
Hi,
these ideas make sense to me, so FWIW,
Acked-by: Pekka Paalanen <pekka.paalanen@xxxxxxxxxxxxx>
Thanks.
There is one nitpick I'd like to ask about:
+bool drm_get_modeset(void)
+{
+ return !drm_nomodeset;
+}
+EXPORT_SYMBOL(drm_get_modeset);
Doesn't "get" have a special meaning in the kernel land, like "take a
strong reference on an object and return it"?
That's a very good point.
As this is just returning bool without changing anything, the usual
word to use is "is". Since this function is also used at most once per
driver, which is rarely, it could have a long and descriptive name.
For example:
bool drm_is_modeset_driver_allowed(void);
I'd nominate
bool drm_native_drivers_enabled()
This is what HW-specific drivers want to query in their init/probing
code. The actual semantics of this decision is hidden from the driver.
It's also easier to read than the other name IMHO
Ok, but what is a "native driver"? Or a "non-native driver"?
Is that established kernel terminology?
I'd think a non-native driver is something that e.g. ndiswrapper is
loading. Is simpledrm like ndiswrapper in a sense? IIRC, simpledrm is
the driver that would not consult this function, right?
Thanks,
pq
Best regards
Thomas
Yeah, naming is hard. Jani also mentioned that he didn't like this
function name, so I don't mind to re-spin the series only for that.
- "drm" is the namespace
- "is" implies it is a read-only boolean inspection
- "modeset" is the feature being checked
- "driver" implies it is supposed gate driver loading or
initialization, rather than modesets after drivers have loaded
- "allowed" says it is asking about general policy rather than what a
driver does
I believe that name is more verbose than needed. But don't have a
strong opinion and could use it if others agree.
Just a bikeshed, I'll leave it to actual kernel devs to say if this
would be more appropriate or worth it.
I think is worth it and better to do it now before the patches land, but
we could wait for others to chime in.
Best regards,
--
Javier Martinez Canillas
Linux Engineering
Red Hat
Attachment:
OpenPGP_signature
Description: OpenPGP digital signature