Re: [PATCH v7 00/45] Add AMD Secure Nested Paging (SEV-SNP) Guest Support

From: Brijesh Singh
Date: Tue Nov 16 2021 - 11:03:37 EST

On 11/16/21 9:45 AM, Venu Busireddy wrote:
On 2021-11-15 10:55:32 -0600, Venu Busireddy wrote:
On 2021-11-15 10:45:48 -0600, Brijesh Singh wrote:

On 11/15/21 10:37 AM, Venu Busireddy wrote:
On 2021-11-15 10:02:24 -0600, Brijesh Singh wrote:

On 11/15/21 9:56 AM, Venu Busireddy wrote:

The series is based on tip/master
ea79c24a30aa (origin/master, origin/HEAD, master) Merge branch 'timers/urgent'

I am looking at,
and I cannot find the commit ea79c24a30aa there. Am I looking at the
wrong tree?


You should use the tip [1] tree .


Same problem with tip.git too.

bash-4.2$ git remote -v
origin (fetch)
origin (push)
bash-4.2$ git branch
* master
bash-4.2$ git log --oneline | grep ea79c24a30aa

Still missing something?

I can see the base commit on my local clone and also on web interface

But can you see the commit ea79c24a30aa if you clone

The web interface has the weird warning "Notice: this object is not
reachable from any branch." Don't know what to make of that.

Just wanted to clarify. I am not interested in the commit ea79c24a30aa
per se. I am trying to apply this patch series to a local copy of the
tip. I tried applying to the top of the tree, and that failed. I tried
to apply on top of commit ca7752caeaa7 (which appeared to be the closest
commit to your description), and that also failed. I just need a commit
on which I can successfully apply this series.

At the time I pulled the tip, the said commit was valid and my entire series was generated against it. Its possible that commit is no longer valid in the recent tip (maybe due to force push). You can grab a staging tree from here