Re: [PATCH 15/15] KVM: X86: Always set gpte_is_8_bytes when direct map

From: Lai Jiangshan
Date: Fri Nov 19 2021 - 05:30:55 EST

On 2021/11/18 23:01, Paolo Bonzini wrote:
On 11/18/21 15:34, Lai Jiangshan wrote:

On 2021/11/18 19:12, Paolo Bonzini wrote:
On 11/18/21 12:08, Lai Jiangshan wrote:
From: Lai Jiangshan <laijs@xxxxxxxxxxxxxxxxx>

When direct map, gpte_is_8_bytes has no meaning, but it is true for all
other cases except direct map when nonpaping.

Setting gpte_is_8_bytes to true when nonpaping can ensure that
!gpte_is_8_bytes means 32-bit gptes for shadow paging.

Then the right thing to do would be to rename it to has_4_byte_gptes and invert the direction.  But as things stand, it's a bit more confusing to make gpte_is_8_bytes=1 if there are no guest PTEs at all.

I will make the last 3 patches be a separated patchset and will do the rename.

Patches 13 and 14 are fine actually.


Since 13, and 14 is queued, could you also queue this one and I will do the rename
separately in the next patchset. I found that the intent of this patch is hidden
in the lengthened squashed patch (of this patch and the renaming patch).