Re: [PATCH v2 12/20] linux/must_be.h: Add must_be() to improve readability of BUILD_BUG_ON_ZERO()

From: Alexey Dobriyan
Date: Sat Nov 20 2021 - 10:05:15 EST

On Sat, Nov 20, 2021 at 02:00:55PM +0100, Alejandro Colomar wrote:
> Historically, BUILD_BUG_ON_ZERO() has been hard to read.
> __must_be_array() is based on BUILD_BUG_ON_ZERO(),
> and unlike BUILD_BUG_ON_*(),
> it has a pretty readable name.

The best name is assert() which userspace uses and is standartised.